[Alliance][Zone] Uldum

Report issues that you found in the Legion repacks
Post Reply
ohyeahsure
Posts: 25
x 1

[Alliance][Zone] Uldum

Post by ohyeahsure » Fri Mar 27, 2020 5:32 pm

Uldum

Level 84-86 Worgen Priest
Client 26972
Normal Account

This time I'm listing all the quests that I encountered and completed.
On the one hand, I only had to use .quest complete once.
On the other hand, there are lots of quests missing. I'm thinking that there must be a bridge quest missing that would like to a new phase for the zone.

Quests:

(27003) Easy Money
Issue: Instant portal, skips some travel and cinematics. It completes fine.

(27922) Traitors!
Issue: hiding behind the plant on the platform doesn't do anything. It should trigger a conversation and complete the quest objective. There is only one plany to hide behind, so it should be obvious where to stand.

(27924) Budd's Plan
Works fine, although the armor pieces keep dropping even after the quest required 6

(28105) Kavem the Callous
Works fine

(27923) Smoke in Their Eyes
Issue: The Torch works on the bales, but the bale also are clickable with a gear cursor, which does nothing. Often multiple clicks on the torch icon are required to get past the notification "Your target is dead"

(28112) Escape From the Lost City
Issue: Might be missing some scripted event or cinematic. As it is, after accepting the quest, you just have to fly up to where King Phaoris is located and turn the quest in.

(28134) Impending Retribution
Works fine

(28870) Return to the Lost City - Dungeon
Works fine

(28781) Targets of Opportunity
Works fine

(28783) The Source of Their Power
Works fine

(28135) Al'Akir's Vengeance
Works fine

(27520) Minions od Al'Akir
Works fine

(28845) The Vortex Pinnacle - Dungeon
Turns in fine once inside the instance

(28760) Vengeance for Orsis
Works fine, but it's a hike back to the quest giver/turn in. I think he normally respawns at the end of the instance.

(28779) A Long Way from Home
Creature (43878) Grand Vizier Ertan
Issue: Doesn't drop quest object (65660) Grand Vizier Ertan's Heart - reset the instance and tried 5 times without a drop. I presume that if the quest is active, the item should drop 100% of the time.
Used .quest complete from a separate account to complete this

(27519) Under the Choking Sands
Issue: most spawn locations have two (45715) Orsis Survivor instead of one. In some instances there is an additional (45716) Orsis Survivor Vehicle (looking like an Imp) that is mountable but immobile.

(27595) The Prophet Hadassi
Works fine

(27602) The Prophet's Dying Words
Works fine

(27623) Colossal Guardians
Issue: (46042) Colossus of the Moon is spawned two times, one is not attackable and doesn't move. There is also a (46087) Orsis Colossus Vehicle at the same location.

(27706) The Scepter of Orsis
Works fine

(27628) Send Word to Phaoris
Works fine, maybe a missing cinematic

Instance Issues:

Instance: The Lost City of Tol'vir
Object: a little carved headstone just inside the entrance of the instance had a blue ? on it, but is not clickable.

Instance: The Votex Pinnacle
Issue: There is no dungeon entrance for the Vortex Pinnacle in the world, had to use Dungeon Finder to get in.

Instance: The Vortex Pinnacle
Creature (45704) Lurking Tempest
Issue: Doesn't move when attacked

Instance: The Vortex Pinnacle
Item: Magic Brazier
Issue: Had a big Blue ? above it, but it is not selectable or clickable


At this point I ran out of quests. I know there are a bunch more, but I couldn't find anything visible while flying over the entire zone. There's a ! on the map in Ramkahen, but nothing on the ground where it's actually usable.



MDic
Posts: 179

Re: [Alliance][Zone] Uldum

Post by MDic » Fri Apr 03, 2020 6:39 pm

This zone is still on the list for future remake and assessment.
I will update when we get to active remake and fixing.

Post Reply